[PLEASE HELP] Can't Update and install package on Ubuntu!

Got my 128MB VPS from MrVM.net and work great for much time (5-6 months). After last REinstallation of ubuntu (i've tried Ubuntu 15 - 16 - 18 - 18 minimal and also Debian) apt update get following error:

    Reading package lists... Done
    W: GPG error: http://archive.ubuntu.com/ubuntu bionic InRelease: At least one invalid signature was encountered.
    E: The repository 'http://archive.ubuntu.com/ubuntu bionic InRelease' is not signed.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: GPG error: http://archive.ubuntu.com/ubuntu bionic-updates InRelease: Couldn't create temporary file /tmp/apt.conf.hAzea6 for passing config to apt-key
    E: The repository 'http://archive.ubuntu.com/ubuntu bionic-updates InRelease' is not signed.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

how can i solve?

I've also tried to reinstall many many times the OS and got NO PUBLICKEY, i've tried to add Public Key with this command apt-key add key.txt but get this error:

E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation ... but i can't update and install packages!!!

Hope you can help me, i have many years of experience on linux in general but this problem is bringing my head into fire!!! Ahahahah

Thank you all guys for help!

Comments

  • Check if your /tmp is full or has proper permission.

  • mikhomikho Hosting ProviderOG

    According to https://www.reddit.com/r/linux4noobs/comments/5dx7rh/gpg_errors_in_ubuntu_1604_when_updating/?utm_source=share&utm_medium=ios_app&utm_name=iossmf

    It will be solved by running
    sudo rm -rf /etc/apt/trusted.gpg.d/*

    I take no responsibility for the suggested solution.

    Thanked by (1)bdl

    Get 4 or more NAT servers (mix/match between packages) and get a 20 % recurring discount. https://clients.mrvm.net

  • Thanks for your reply.

    /tmp permission is

    root[0]
    root[0]
    rwxrwxrwt (1777)
    

    I've already tried rm -rf /etc/apt/trusted.gpg.d/* in last days but I tried again to do it, Now i got different message:
    (NO_PUBKEY)

    [email protected]:/# rm -rf /etc/apt/trusted.gpg.d/*
    [email protected]
    [email protected]:/# apt update
    Hit:1 http://archive.canonical.com/ubuntu bionic InRelease
    Get:3 http://archive.ubuntu.com/ubuntu bionic InRelease [242 kB]
    Get:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
    Err:1 http://archive.canonical.com/ubuntu bionic InRelease
      The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    Get:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
    Err:3 http://archive.ubuntu.com/ubuntu bionic InRelease
      The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    Err:2 http://security.ubuntu.com/ubuntu bionic-security InRelease
      The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    Err:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
      The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    Reading package lists... Done
    W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive.canonical.com/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    W: GPG error: http://archive.ubuntu.com/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    E: The repository 'http://archive.ubuntu.com/ubuntu bionic InRelease' is not signed.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: GPG error: http://security.ubuntu.com/ubuntu bionic-security InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    E: The repository 'http://security.ubuntu.com/ubuntu bionic-security InRelease' is not signed.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: GPG error: http://archive.ubuntu.com/ubuntu bionic-updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    E: The repository 'http://archive.ubuntu.com/ubuntu bionic-updates InRelease' is not signed.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    

    What i need now is to add the PUBKEY (and this should be simple) , so i go on http://keyserver.ubuntu.com/ and past my "NO_PUBKEY 3B4FE6ACC0B21F32" i need to paste it on website adding 0x, so 0x3B4FE6ACC0B21F32, then i get PUBKEY to add on my server, copy and past it on /home/key.txt (with 755 permission, to make it work smoothly).

    Now I should be ready to solve, I proceed with the command:

    http://[email protected]/# cd /home/
    http://[email protected]/# apt-key key.txt
    

    ERROR (I KNEW IT!!)

    E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation

    I need to install the package, so i need to doapt update and apt install gnupg2(or gnupg or gnupg1)

    i can't do apt update so i've tried apt install gnupg and apt install gnupg1

    With apt install gnupg i got:

    Package gnupg is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'gnupg' has no installation candidate
    

    With apt install gnupg1 i got:

    Package gnupg1 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'gnupg1' has no installation candidate
    

    only apt install gnupg2 give me this error:

    Package gnupg2 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
      gpgv
    
    E: Package 'gnupg2' has no installation candidate
    

    I hope all these steps are useful to someone, in my case unfortunately they did not solve the problem and i'm still searching a solution

  • edited September 12

    you could search for packages needed for whatever you are on right now and download them directly and install via dpkg, though I guess gnupg will depend on quite some more packages which might be missing as well... https://packages.ubuntu.com/bionic/gnupg

    you could also do something like
    apt -o Acquire::AllowInsecureRepositories=true -o Acquire::AllowDowngradeToInsecureRepositories=true update
    to get your update of packages and maybe
    apt-get --allow-unauthenticated upgrade
    or install to get missing packages. weird anyway, that this does not work correctly even after reinstall.

  • RahulRahul OG
    edited September 12

    @DalaDala

    What happens when you do a

    apt upgrade

    Do you get any progress with that ?

    after that try

    apt update

    Best to do after another clean, but also try in current state too.

    I have a hunch that I have came across this particular issue.

  • This is df -h (this is important to know for help)

    [email protected]:~# df -h
    Filesystem         Size  Used Avail Use% Mounted on
    /dev/ploopX   2.9G  271M  2.5G  10% /
    none                64M     0   64M   0% /sys/fs/cgroup
    none                64M     0   64M   0% /dev
    tmpfs               64M     0   64M   0% /dev/shm
    tmpfs               64M  108K   64M   1% /run
    tmpfs              5.0M     0  5.0M   0% /run/lock
    none                64M     0   64M   0% /run/shm
    

    This is apt upgrade

    [email protected]:~# apt upgrade
    Reading package lists... Done
    Building dependency tree... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    

    and this is apt -o Acquire::AllowInsecureRepositories=true -o Acquire::AllowDowngradeToInsecureRepositories=true update after @Falzo help

    [email protected]:~# apt -o Acquire::AllowInsecureRepositories=true -o Acquire::AllowDowngradeToInsecureRepositories=true update
    Hit:1 http://archive.canonical.com/ubuntu bionic InRelease
    Get:2 http://archive.ubuntu.com/ubuntu bionic InRelease [242 kB]
    Get:4 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
    Get:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
    Err:1 http://archive.canonical.com/ubuntu bionic InRelease
      The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    Ign:4 http://security.ubuntu.com/ubuntu bionic-security InRelease
    Get:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [849 kB]
    Get:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [264 kB]
    Get:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages [87.3 kB]
    Get:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en [18.8 kB]
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Ign:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
    Ign:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en
    Ign:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
    Ign:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages
    Ign:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en
    Ign:2 http://archive.ubuntu.com/ubuntu bionic InRelease
    Get:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [232 kB]
    Get:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [232 kB]
    Get:11 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages [1019 kB]
    Get:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [232 kB]
    Get:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [232 kB]
    Get:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [232 kB]
    Get:12 http://archive.ubuntu.com/ubuntu bionic/main Translation-en [516 kB]
    Get:13 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages [9184 B]
    Get:14 http://archive.ubuntu.com/ubuntu bionic/restricted Translation-en [3584 B]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:16 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages [8512 B]
    Get:17 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en [2908 B]
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Ign:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
    Ign:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
    Ign:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en
    Ign:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
    Ign:11 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
    Ign:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages
    Ign:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en
    Ign:12 http://archive.ubuntu.com/ubuntu bionic/main Translation-en
    Ign:13 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages
    Ign:14 http://archive.ubuntu.com/ubuntu bionic/restricted Translation-en
    Ign:18 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en
    Ign:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
    Ign:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
    Ign:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [897 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Get:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
    Ign:11 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
    Ign:12 http://archive.ubuntu.com/ubuntu bionic/main Translation-en
    Ign:13 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages
    Ign:14 http://archive.ubuntu.com/ubuntu bionic/restricted Translation-en
    Ign:19 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
    Ign:20 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en
    Ign:21 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
    Ign:22 http://archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en
    Ign:23 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
    Ign:24 http://archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en
    Ign:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
    Ign:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
    Get:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [378 kB]
    Ign:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en
    Get:18 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en [4941 kB]
    Get:18 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en [4941 kB]
    Get:18 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en [4941 kB]
    Get:18 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en [4941 kB]
    Ign:19 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
    Get:18 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en [4941 kB]
    Get:18 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en [4941 kB]
    Ign:20 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en
    Ign:21 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
    Ign:22 http://archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en
    Ign:23 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
    Ign:24 http://archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en
    Ign:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en
    Ign:18 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en
    Ign:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages
    Ign:11 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
    Ign:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en
    Ign:12 http://archive.ubuntu.com/ubuntu bionic/main Translation-en
    Err:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
      Write error - write (28: No space left on device)
    Ign:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
    Ign:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en
    Ign:13 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages
    Ign:14 http://archive.ubuntu.com/ubuntu bionic/restricted Translation-en
    Ign:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
    Ign:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en
    Ign:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages
    Ign:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en
    Ign:19 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
    Ign:20 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en
    Ign:21 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
    Ign:22 http://archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en
    Ign:23 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
    Ign:24 http://archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en
    Ign:18 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en
    Err:11 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
      Write error - write (28: No space left on device)
    Ign:12 http://archive.ubuntu.com/ubuntu bionic/main Translation-en
    Ign:13 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages
    Ign:14 http://archive.ubuntu.com/ubuntu bionic/restricted Translation-en
    Ign:15 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
    Err:19 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
      Could not create temporary file for /var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_bionic-updates_main_binary-amd64_Packages - mkstemp (28: No space left on device)
    Ign:20 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en
    Ign:21 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
    Ign:22 http://archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en
    Ign:23 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
    Ign:24 http://archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en
    Fetched 1192 kB in 4s (285 kB/s)
    Reading package lists... Done
    W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive.canonical.com/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    W: GPG error: http://security.ubuntu.com/ubuntu bionic-security InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    W: The repository 'http://security.ubuntu.com/ubuntu bionic-security InRelease' is not signed.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: GPG error: http://archive.ubuntu.com/ubuntu bionic InRelease: At least one invalid signature was encountered.
    W: The repository 'http://archive.ubuntu.com/ubuntu bionic InRelease' is not signed.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: GPG error: http://archive.ubuntu.com/ubuntu bionic-updates InRelease: At least one invalid signature was encountered.
    W: The repository 'http://archive.ubuntu.com/ubuntu bionic-updates InRelease' is not signed.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: Failed to fetch http://archive.canonical.com/ubuntu/dists/bionic/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/bionic-security/main/binary-amd64/Packages  Write error - write (28: No space left on device)
    E: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic/main/binary-amd64/Packages  Write error - write (28: No space left on device)
    E: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic-updates/main/binary-amd64/Packages  Could not create temporary file for /var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_bionic-updates_main_binary-amd64_Packages - mkstemp (28: No space left on device)
    W: Some index files failed to download. They have been ignored, or old ones used instead.
    

    NOTE: Still present " NO_PUBKEY 3B4FE6ACC0B21F32 " in logs

  • tried to download and install gnupg from https://packages.ubuntu.com/bionic/amd64/gnupg/download but every dependency have 4+ dependency.. i need to download and install many .deb package (probably i need some weeks)

    I don't understand what caused this problem ... yet the system is clean and freshly installed and I reinstall it at each test to try more solutions. Right now the VPS is unusable as I can't install anythings with apt, this is weird problem

  • @DalaDala said:
    tried to download and install gnupg from https://packages.ubuntu.com/bionic/amd64/gnupg/download but every dependency have 4+ dependency.. i need to download and install many .deb package (probably i need some weeks)

    I don't understand what caused this problem ... yet the system is clean and freshly installed and I reinstall it at each test to try more solutions. Right now the VPS is unusable as I can't install anythings with apt, this is weird problem

    So why not

    apt -o Acquire::AllowInsecureRepositories=true -o Acquire::AllowDowngradeToInsecureRepositories=true install gnupg

    The wise receive respect. The dumb demand respect.

  • Sometimes "apt clean" helps with cleaning the cached downloaded content.

    apt clean
    apt update
    apt upgrade
    

    The wise receive respect. The dumb demand respect.

  • @DalaDala said:
    Write error - write (28: No space left on device)

    So you are running out of space. "apt clean" before other apt operations might help. You may want to check which partition is running out of space and make some space by deleting unwanted content before apt operations.

    Thanked by (1)comi

    The wise receive respect. The dumb demand respect.

  • I'm a bit puzzled as well but here are some (more possibly useless) thoughts:

    1. Could be there's not enough RAM (128MB maybe a bit tight for some operations?)
    2. Is this a template issue?
    3. Crude hack - try to copy the /etc/apt/ folder (use rsync, copy recursively) from a working/good/bigger machine where apt-get update is working - this will at least get you the trusted keys which may help overcome that initial stumbling block (i.e. good files in /etc/apt/trusted.gpg.d/ )
    4. Can you keep a dstat running (say via screen or another SSH session and yes I know this may make memory pressure worse) but at least you'll know if the space left on device error is genuine or spurious of if there's any memory issue - BTW, did you check the logs for any OOM messages)
  • edited September 12

    Thanks for your reply @nullnothere

    These are my tests and reply:
    1. I'm using 128mb VPS since 3 years and they have always worked well, i've also installed ts3 server and used it for months! Somewhere there are also 64mb vps but i think 128mb is the minimum acceptable;
    2. I don't understand what do you mean with "Template", if you mean Ubuntu version => i've tried Ubuntu 15, 16, 18 and 18 minimal (also debian);
    3. I've tried this right now, it fix only the missing KEY (fix NO_PUBKEY 3B4FE6ACC0B21F32) but i still have apt problem, see following NOTE;
    4. i don't have dstat installed, i search on google how to deal with it

    NOTE

    [email protected]:/home# apt-get update
    Get:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
    Get:2 http://archive.ubuntu.com/ubuntu bionic InRelease [242 kB]
    Hit:4 http://archive.canonical.com/ubuntu bionic InRelease
    Get:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
    Get:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [849 kB]
    Get:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [264 kB]
    Get:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages [87.3 kB]
    Get:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en [18.8 kB]
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Ign:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
    Ign:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
    Ign:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en
    Get:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [849 kB]
    Ign:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Ign:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en
    Ign:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Ign:11 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages
    Err:4 http://archive.canonical.com/ubuntu bionic InRelease
      At least one invalid signature was encountered.
    Ign:12 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en
    Err:2 http://archive.ubuntu.com/ubuntu bionic InRelease
      Couldn't create temporary file /tmp/apt.conf.4epOCX for passing config to apt-key
    Ign:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
    Err:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
      Couldn't create temporary file /tmp/apt.conf.6ymFA0 for passing config to apt-key
    Ign:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en
    Ign:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages
    Ign:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [701 kB]
    Ign:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
    Ign:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en
    Get:11 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages [8512 B]
    Get:12 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en [2908 B]
    Ign:11 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages
    Ign:12 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en
    Ign:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
    Ign:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en
    Ign:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages
    Ign:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en
    Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [897 kB]
    Ign:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
    Ign:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en
    Ign:11 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages
    Ign:12 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en
    Err:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
      Could not create temporary file for /var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_bionic-security_main_binary-amd64_Packages - mkstemp (28: No space left on device)
    Ign:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en
    Ign:7 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages
    Ign:8 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en
    Ign:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
    Ign:10 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en
    Ign:11 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages
    Ign:12 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en
    Reading package lists... Done
    W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive.canonical.com/ubuntu bionic InRelease: At least one invalid signature was encountered.
    W: GPG error: http://archive.ubuntu.com/ubuntu bionic InRelease: Couldn't create temporary file /tmp/apt.conf.4epOCX for passing config to apt-key
    E: The repository 'http://archive.ubuntu.com/ubuntu bionic InRelease' is not signed.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: GPG error: http://archive.ubuntu.com/ubuntu bionic-updates InRelease: Couldn't create temporary file /tmp/apt.conf.6ymFA0 for passing config to apt-key
    E: The repository 'http://archive.ubuntu.com/ubuntu bionic-updates InRelease' is not signed.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    

    i think signature error depending on this error Couldn't create temporary file /tmp/apt.conf.4epOCX for passing config to apt-key. Now i'm focused to solve this tmp file creation, i try.

    Anyway apt-clone can be a solution but i can't install it because it have many, many, many dependencies. (but this can help someone, i hope).

    However, I want to thank everyone for the help and explanations you are giving me, we are facing the problem head on!

    Thanked by (1)nullnothere
  • @KamalW

    already tried apt-clean unfortunately is not the solution in my case

  • AbdullahAbdullah Hosting ProviderOG
    edited September 12

    @DalaDala as you say already tried reinstalling the os, that should have fixed the issue.
    It is maybe an os template or container problem, you should create a ticket.

  • mikhomikho Hosting ProviderOG

    There were multiple errors here.

    Here is what was made to fix the issue in total.

    rm -rf /etc/apt/trusted.gpg.d/*
    edit /etc/apt/sources.list
    add [trusted=yes] to every repo
    Example: deb [trusted=yes] http://localmachine/debian wheezy main

    run:
    apt --fix-broken install
    run:
    apt-get update

    apt-key adv –keyserver keyserver.ubuntu.com –recv-keys 3B4FE6ACC0B21F32
    if this fails (it did on the VPS) due to a shared library was missing
    run:
    apt-get install gnupg
    and then re-run the
    apt-key adv command

    Thanked by (2)nullnothere Falzo

    Get 4 or more NAT servers (mix/match between packages) and get a 20 % recurring discount. https://clients.mrvm.net

  • Thanks to @mikho and all of you for your help! Now everything works like a charm!

    Thanked by (1)vimalware
  • mikhomikho Hosting ProviderOG

    @mikho said:
    There were multiple errors here.

    Here is what was made to fix the issue in total.

    rm -rf /etc/apt/trusted.gpg.d/*
    edit /etc/apt/sources.list
    add [trusted=yes] to every repo
    Example: deb [trusted=yes] http://localmachine/debian wheezy main

    run:
    apt --fix-broken install
    run:
    apt-get update

    apt-key adv –keyserver keyserver.ubuntu.com –recv-keys 3B4FE6ACC0B21F32
    if this fails (it did on the VPS) due to a shared library was missing
    run:
    apt-get install gnupg
    and then re-run the
    apt-key adv command

    remember to remove [trusted=yes] from /etc/apt/sources.list when all is done.

    Get 4 or more NAT servers (mix/match between packages) and get a 20 % recurring discount. https://clients.mrvm.net

  • vyasvyas OGContent Writer
Sign In or Register to comment.