OpenVZ 7 : Telegram MTproto-proxy segmentation fault

After my vps at Gullo upgraded my vps to openvz 7
i cannot setup and run telegram mtproto proxy anymore
i have done this many times , on many vps in the past without any problem.

but this time on openvz 7 , when i run it , it shows only "segmentation fault"
i tried almost all OS Debian 9, 10, ubuntu 14, 16, 18 ... all shows same error

so i can assume it is related to openvz 7

Please , can some one help me to solve this ?

Comments

  • It may be better to contact the developer of the software than us folks here, if you haven't already. Does this software require some sort of kernel module to be loaded? That definitely won't work with OpenVZ.

    Does the same software work in a KVM VPS? That will help conclusively rule out if the issue is with the underlying virtualization system.

    Cheap dedis are my drug, and I'm too far gone to turn back.

  • Try running strace. If you don't know what that is, you're going to need to do a little bit of research and provide further information. We don't know what it's crashing, but that will help you step through.

    My pronouns are asshole/asshole/asshole. I will give you the same courtesy.

  • @CamoYoshi said:
    It may be better to contact the developer of the software than us folks here, if you haven't already. Does this software require some sort of kernel module to be loaded? That definitely won't work with OpenVZ.

    Does the same software work in a KVM VPS? That will help conclusively rule out if the issue is with the underlying virtualization system.

    Thank you very much.
    As i said , i installed this software on many vps in the past , all of them was OpenVZ , but after the provider upgraded my service to openvz 7 this problem started.

  • @WSS said:
    Try running strace. If you don't know what that is, you're going to need to do a little bit of research and provide further information. We don't know what it's crashing, but that will help you step through.

    #strace ./mtproto-proxy 
    
    execve("./mtproto-proxy", ["./mtproto-proxy"], [/* 18 vars */]) = -1 ENOMEM (Cannot allocate memory)
    --- SIGSEGV {si_signo=SIGSEGV, si_code=SI_KERNEL, si_addr=0} ---
    +++ killed by SIGSEGV +++
    Segmentation fault
    

    As far as i can see , it's related to low free memory. It's a 128MB service , but i didn't have this problem on 128MB services in the past.
    Maybe OpenVZ 7 provide less free memory
    and here is the "free" command output:

    # free
                  total        used        free      shared  buff/cache   available
    Mem:         131072       15556       71428         940       44088      112636
    Swap:             0           0           0
    
  • AnthonySmithAnthonySmith AdministratorHosting Provider

    Simple answer then, find a host still using OpenVZ 6 or better yet find one still using OpenVZ 5 it should run even better :)

    newer platforms tend to require more resorces, its also possible your hosts vz7 templates are the standard none minimal ones, so you will need to strip down your VPS further.

    tbh issues like this are the reason I upgraded the NAT VPS packages I sell to 256MB minimum.

    Inception Hosting - 256MB OpenVZ VPS back in stock for €8.00 p/year - DEDICATED IP4 + /64 IPv6 https://clients.inceptionhosting.com/cart.php?a=add&pid=177

  • Temporary i solved my problem by switching to "Python3 implementation of Telegram MTProto-proxy" by alexbers :
    https://github.com/alexbers/mtprotoproxy

    Thanked by (2)AnthonySmith CamoYoshi
Sign In or Register to comment.